Chris Marshall jns-cmarshall at
Sun Dec 19 15:46:09 EST 2010

I was able to run the StarTech USB2VGA2 on
an XO-1 with os359 installed.  It came up
at a resolution of 1024x768.

I looked for a mode for 1360x768 resolution
for my HDTV but could not find one.  I tried
setting up a 1280x768 resolution but that
displayed shifted to the left so the left part
of the screen was not visible on the display
(I could only see from the Neighborhood view
button to the right of the Sugar desktop).

It would be nice if there were more options
for resolutions checked out and available in
the xorg.conf (even if commented out).

Has anyone tried to show a 1280x768 output
for os359 and Sugar on the XO-1?  The HDTV
recommends 1360x768 as "optimal" but it
doesn't look like the USB2VGA2 supports


On 12/8/2010 7:35 AM, Kevin Gordon wrote:
> Thanks Sameer,
> The only difference I've ever seen between the dongles is on the Mac 17" Powerbook.  With the USB2VGA2 I can mirror the full 1920x1200 display, with the earlier one, USB2VGA, it seems I can just get it to 1680x1050.  I usually carry the USB2VGA2 when on the road,  since some vendor's  machines have DVI, mini-DVI, or various HDMI or DisplayPorts as outputs, and then there are the various  projector inputs.  It's nice to just have to carry one as no matter what vendors are in place, most computers have a free USB port, and most projections systems still have VGA inputs.  So, if there is a native 1920x1200 source, no matter what manufacturer, I plug in the USB and I can mirror.  I can use a Mac, a Dell, with their funky external ports, with any flavour of Windows, OSX or Ubuntu 10.x. (caveat being able to have authority to auto-install drivers, of course)
> As for price, just recently at Tiger Direct, the newer USB2VGA2 is actually $5 cheaper than the old one.  It used to be $25 more.
> I will play with XRandR to try to switch back and forth, good point. I've never used it at that 'level', I've used GRandR on an older Ubuntu with an F7-hot key patch, but not in quite some time - since my 10.04 install seems to meet my rather minimal plug and play requirements natively now.  I'll get back to you on the XO tests,and look at the --q output to see if the XO reports any difference in the dongles.  Thanks again.
> Cheers
> KG
> On Tue, Dec 7, 2010 at 4:29 PM, Sameer Verma <sverma at <mailto:sverma at>> wrote:
>     On Tue, Dec 7, 2010 at 10:24 AM, Kevin Gordon <kgordon420 at <mailto:kgordon420 at>> wrote:
>      > I have set up a little XO test environment for USB to external VGA.  I've
>      > done minimal testing, but if anyone would like me to try anything
>      > specifically, or give me a detailed test plan, please let me know.
>      >
>      > Here is what I have
>      >
>      > 1 XO 1.5 running os4
>      > 1 XO 1.5 running 357
>      > 1 XO 1.0 running os4
>      > 1 XO 1.0 running 357
>      >
>      > 1 Startech USB2VGA
>      > 1 Startech USB2VGA2
>      >
>      > 1 Dell 23" with VGA cable
>      > 1 HP 55" with VGA cable.
>      >
>      > Out of the box what I have noticed in a very simple plug-and-play set of
>      > tests is:
>      >
>      > Both 1.5's with both Startechs, with both monitors:  If the monitor is
>      > already turned on, and already plugged into the USB port on the XO 1.5
>      > before cold boot, the external monitor becomes active and looks fantastice,
>      > every time.  This works on both the Sugar and Gnome boots.  System doesnt
>      > seem to care if anyting else has been plugged into the USB port between
>      > boots, still comes up first time every time.
>      >
>      > Both 1.0's with both Startechs with both monitors:  If the monitor is
>      > already turned on, and already plugged into the USB port on the XO 1.0
>      > before cold boot, the external monitor becomes active and looks fantastic,
>      > most the time.  This is the case on both the Sugar and Gnome boots.  The
>      > most the time comes from :  If I have plugged a different USB device into
>      > the port between boots, the XO 1.0 stalls at the 'third dot around the
>      > circle' during boot and flashes the external monitor.  This stall does not
>      > seem to exit. The only exit n my arsenal is the power off button.  However,
>      > on the subsequent boot, not having swapped any different USB device, that
>      > boot goes right round the circle, and activates the external monitor.
>      >
>      > The above seems a bit strange, but it is consistent.
>      >
>      > I have had absolutely no success in plugging any adapter with any monitor
>      > into any of the XO's after XO is up.  LSUSB recognizes the adapter, but
>      > doesn't activate the external monitor.
>      >
>      > I have had no success in unplugging the adapter while the external monitor
>      > is active.  The internal XO display does not come back active, and
>      > replugging the external adapter does not bring the external monitor back
>      > active.  Oops, now need to Power off again.
>      >
>      > Another little note, when the external becomes active when booting the Sugar
>      > desktop, the internal display goes blank, once the External goes active.
>      > When booting on the Gnome side, the internal display continues to display a
>      > sort of console output, but it remains static.
>      >
>      > Again, if anyone wants me to test other things, or any specific
>      > combinations, please let me know.  I may need instructions to monitor what
>      > you want to see, (I.e.; I'm sure there are guffaws and giggling about my
>      > comment 'third dot around the circle'); but,  I'm willing to learn.
>      >
>      > Cheers
>      >
>      > KG

More information about the Devel mailing list