XO-1.5 ebook switch driver - upstream submission

Daniel Drake dsd at laptop.org
Sat Dec 4 13:04:35 EST 2010

On 4 December 2010 18:03, Chris Ball <cjb at laptop.org> wrote:
> Hi Dan,
>   >  - driver renamed to "xo1p5-ebook"
> Not sure where the 'p' comes from -- how about "xo1_5-ebook"?
> We could do the same on 1.75, e.g. olpc-ec-1_75.c.

It's only a detail, but...

I was thinking that it makes sense to use something other than _ as
the decimal point (p is for point).
This is because in function names you can't use -, so _ becomes the
natural equivalent of space.
Under your suggestion there would be xo1_5_ebook_init() where theres
no consistent meaning of _ (first one represents a decimal point in a
version number, 2nd and 3rd one are word separators).


More information about the Devel mailing list