FW: Update for geode driver

Huang, FrankR FrankR.Huang at amd.com
Sun Aug 15 21:19:43 EDT 2010


	I am very glad to get the feedback from you. Still some patches need to be committed later(although no new bug is reported still).
	Hope you can report anything you think incorrect or abnormal after using that new driver.
	For "NoAccel" segfault, I am not sure if you have tried Mart's patch in the below link:
	I have given a try and it can nicely solve this bug. It is caused by the zero pointer use. Could you give a try? I think Mart know more about that.


	Can you make this issue more clear for Bernie?


> -----Original Message-----
> From: Bernie Innocenti [mailto:bernie at codewiz.org]
> Sent: 2010年8月15日 10:13
> To: Huang, FrankR
> Cc: OLPC Devel
> Subject: Re: Update for geode driver
> El Fri, 13-08-2010 a las 10:35 +0800, Huang, FrankR escribió:
> > Bernie,
> >
> > 	You can git clone the lastest code from freedesktop for geode driver
> > to use. The most outstanding rendering bug has been fixed. And some
> > performance patch has been applied.
> I tested the driver on the XO-1 and couldn't spot any rendering bug
> neither in Sugar nor in Gnome, with full acceleration enabled and no
> quirks needed in xorg.conf.
> However, a long-standing bug is still there: setting Option "NoAccel"
> "1" makes the driver segfault during startup.
> Thank you very much for taking the time to do this neat work, Frank!
> (pls forward my notes the geode list, I'm not subscribed)
> --
>    // Bernie Innocenti - http://codewiz.org/
>  \X/  Sugar Labs       - http://sugarlabs.org/

More information about the Devel mailing list