[Sugar-devel] Problem installing and running hulahop on ubuntu 8.10

vijit singh vijitthetopcoder at gmail.com
Fri Sep 4 17:37:11 EDT 2009

Hi Tomeu,

> #
> /var/lib/python-support/python2.5/xpcom/xpt.py:72: RuntimeWarning:
> tp_compare didn't return -1 or -2 for exception
> I think this is due to some python C modules being compiled with a
> python version and others with a different version.

I think this is a runtime warning and not an error, so the exception which
is coming in the log is not because of this warning. Still I tried removing
python2.4 and running only with python2.5 to ensure only one python version
is throughout, if that is what you wanted to say. Still, the same problem

I think the error is because it is unable to include xpt.py module, however
this is very strange because on line no 16 at http://pastebin.be/20740 , xpt
is imported properly, which means the libraries are connected properly, but
when we again try to include it in line 24, it gives error. The only
difference b/w line 16 and line 24 is that at the latter one it tries to
include it from a folder not in the same location as the module while in the
former one it was imported from the same folder. Any suggestions ?

Anyways, I also tried including the /var/lib/python-support/python2.5/xpcom/
path also before running python by giving the following command-

LD_LIBRARY_PATH=/var/lib/python-support/python2.5/xpcom/ :
/usr/lib/xulrunner- python

but still the same problem is occuring. Kindly give your suggestions.


Is there anyone who has tried running hulahop on ubuntu8.10 or anyother
version of ubuntu. Did anyone else faced similar problems?

VIJIT aka sumit

> Can you check?
> Regards,
> Tomeu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20090905/9083e07d/attachment.html>

More information about the Devel mailing list