[Server-devel] Early F11 XS build

Jerry Vonau jvonau at shaw.ca
Mon Oct 26 13:42:21 EDT 2009

On Mon, 2009-10-26 at 10:52 +0100, Martin Langhoff wrote:
> On Mon, Oct 26, 2009 at 1:17 AM, Jerry Vonau <jvonau at shaw.ca> wrote:
> > Is this with anaconda or with your XO image? I've booted F11's anaconda
> > that was released on the dvd in my prior testing.
> XO image - I'll try tomorrow with the kernel you report as working -
> and if that works report a bug against the (newer) one I ended up
> getting.
> > No, you just need files from /isolinux & /images on the dvd or disc1...
> > Doesn't mkusbinstall work anymore?
> Frankly I didn't try it with the XS iso, but assumed it'd be the same
> as with the F11 DVD. Will try.
> Earlier, when preparing the installer for my build machine (which has
> no DVD/CD reader), mkusbinstall (running on a F9 host) did not work
> for me with the F11 DVD, and I found some instructions that fixed it,
> by downloading the netboot iso and placing it in /images.
What error did anaconda throw up? Got a link to those instructions? 
I needed to run an update.img to get the installer to see my install
when I was upgrading my workstation, can't recall if that problem
extended to the usb install method.  

> Maybe there was PEBKAC and/or just a better fix (hints?). I just hope
> the instructions for our end users can be simple :-)
I'm re-testing now, but I'm on a F11 host... 
Ok, see two issue, I forgot that the behaviour of method= changed
between F9 & F11. We now need to make use of stage2= in place of
method=(method is going away, anyway). Second is we are assuming with
sed that there is a ks= in the line we're replacing.   

> > confusing anaconda over method/repo/stage2. Edit the sed replacement
> > line replacing method= with repo=, the inner workings are slightly
> > different between F9 and F11.
> thanks! - I'll fix that :-)
Working up a patch

> cheers,
> m


More information about the Devel mailing list