Problem creating .xo bundle

Art Hunkins abhunkin at
Tue Jun 23 15:34:15 EDT 2009

As mentioned in a previous message, I *was* able to build a bundle on my 
WinXP system by zipping the Activity directory with its subdirectory, and 
renaming the zip to OurMusic-1.xo (this is version 1).

Placing the file on a thumb drive, I was able to install the activity with 
the sugar-install-bundle command as described on p.117 of the OLPC User 

Strangely, though, preparing a USB drive as described also on p.117 (but 
under "Installing a Set of Activities"), and placing my .xo in the bundles 
directory, it did *not* install the activity (nothing apparently happened). 
I followed the procedure to the letter. I can't locate anything in the log 
files to indicate what went wrong either.

I'm wondering:

Do either or MANIFEST need to be present in the .xo for the above 
to work? (I *did* include them though.)

Does (and any other scripts) need to have x permission for this 
auto-install method? (I don't suppose so, though they did *not* have such 

Art Hunkins

----- Original Message ----- 
From: "Art Hunkins" <abhunkin at>
To: "Gary C Martin" <gary at>
Cc: <devel at>; <walter.bender at>
Sent: Tuesday, June 23, 2009 12:28 PM
Subject: Re: Problem creating .xo bundle

> Thanks for the reply, Gary (Aaron as well!)
> Yes, execute permissions are set correctly for
> My file reads exactly the same as yours.
> I'm still getting the same problemmatic results as below.
> I'm developing largely on the XO itself, with help from my Windows (XP) 
> computer and some thumb drives. I'm using the XO's builtin nano editor.
> My XO build is 802, with Q2E41 firmware. As I recall, I'm working with a 
> developer key, FWIW.
> Any further ideas?
> Art Hunkins
> ----- Original Message ----- 
> From: "Gary C Martin" <gary at>
> To: "Art Hunkins" <abhunkin at>
> Cc: <devel at>; <walter.bender at>
> Sent: Monday, June 22, 2009 11:05 PM
> Subject: Re: Problem creating .xo bundle
>> Hi Art,
>> On 23 Jun 2009, at 03:40, Art Hunkins wrote:
>>> I've got an XO Activity ready to go, and working perfectly in my (XO)
>>> Activities folder. (It's called OurMusic.activity.)
>>> I just can't seem to make an .xo bundle of it.
>>> From my activity's folder (OurMusic.activity) I run:
>>> ./ dist_xo
>>> and get:
>>> : No such file or directory
>>> If I run:
>>> dist_xo
>>> or just
>>> I get:
>>> bash: command not found
>>> (and is right there in the folder, with correct permissions.)
>> Hmmm, so does have execute permissions (chmod +x
>>> Can someone give me guidance, please? (Happy to send along my,
>>> MANIFEST and files if relevent.)
>> My's just look like this:
>> #!/usr/bin/env python
>> from sugar.activity import bundlebuilder
>> bundlebuilder.start()
>> Running ./ on its own should just give you its usage 
>> instructions.
>> What environment are you developing under? Might give us some more  clues 
>> :-)
>> Regards,
>> --Gary
>> P.S. You might want to join the sugar-devel mail-list 
>> ( ), that's where most of 
>> the current folks working on Sugar/Activities  are.

More information about the Devel mailing list