Problem running Sugar on openSUSE 11.0

James Simmons jim.simmons at
Thu Jan 22 12:02:29 EST 2009


I upgraded to open SUSE 11.1 last night, added the repositories and 
installed sugar and sugar-activities as you instructed.  Everything 
seemed to install just fine, except that sugar-activities said it 
required etoys and that was not available.  It did let me ignore this 
dependency and continue.

When I tried to logout and log back in with a Sugar session instead of 
my usual WindowMaker the screen went black for a bit, then I found 
myself at the login prompt.  I tried it a couple of times.  Then I 
logged back in using WindowMaker and tried to run "sugar" at the command 
prompt.  I got a stack trace with a message saying module "hippo" was 
not found.  I went to Yast and found that there were a couple of Hippo 
Canvas RPMs that were not installed, so I tried installing those.  
Running "sugar" gave me this:

matchbox-window-manager: Failed to connect to session manager
root window unavailible (maybe another wm is running?)
g: the sha module is deprecated; use the hashlib module instead
  import sha
Traceback (most recent call last):
  File "/usr/bin/sugar-session", line 41, in <module>
    from jarabe.desktop.homewindow import HomeWindow
  File "/usr/lib/python2.6/site-packages/jarabe/desktop/", 
line 24,
 in <module>
    from jarabe.desktop.meshbox import MeshBox
  File "/usr/lib/python2.6/site-packages/jarabe/desktop/", 
line 35, in
    from sugar.activity import activityfactory
"/usr/lib/python2.6/site-packages/sugar/activity/", lin
e 29, in <module>
    from sugar.presence import presenceservice
"/usr/lib/python2.6/site-packages/sugar/presence/", lin
e 32, in <module>
    from sugar.presence.activity import Activity
  File "/usr/lib/python2.6/site-packages/sugar/presence/", 
line 27, i
n <module>
    import telepathy
ImportError: No module named telepathy

I tried YAST again to see if telepathy was installed.  It looked to me 
like it was.  There were a few RPMs related to telepathy that I had not 
installed, but none of them looked relevant to Sugar so I didn't try to 
install them.  So this is where I am now and I hope you can suggest 

I appreciate the work you put in creating this, by the way, even though 
I haven't got it working yet.  My current Sugar test environment in on 
another machine running Xubuntu and while it was very easy to set up it 
is incomplete, buggy, and badly out of date.

Also, it looks like your version of Sugar does not make use of Zephyr to 
run in a window like sugar-jhbuild does.  I find being able to run 
multiple instances of the Sugar environment on the same box very useful 
for testing the sharing features that all Sugar activities should 
support.  Is there a way to run what you have created this way?

Thanks again,

James Simmons

Jigish Gohil wrote:
> On Mon, Jan 19, 2009 at 8:33 PM, James Simmons
> <jim.simmons at> wrote:
>> Cyberorg,
>> I recently upgraded my PC from openSUSE 10.2 to openSUSE 11.0.
> Hi
> Please update to openSUSE 11.1, add the following repositories before
> installing sugar and sugar-activities packages:
> Cheers
> -J

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list