Problem running Sugar on openSUSE 11.0

James Simmons jim.simmons at
Mon Jan 19 10:03:36 EST 2009


I recently upgraded my PC from openSUSE 10.2 to openSUSE 11.0.  On my 
previous installation I had used sugar-jhbuild to compile and run the 
Sugar environment.  It was not fully functional, but it worked OK for 
what I needed it for.  However, after upgrading my XO to the latest 
Sugar I realized that I needed a better Sugar environment.

I upgraded openSUSE to 11.0, deleted my sugar-jhbuild directory and 
started over.  I kept failing because it was looking for libraries in 
/opt/gnome/lib that I didn't have.

I looked on the SUSE page ( to 
see what advice I could get and found your install instructions for 
zypper.  I tried them out and they *seemed* to work just fine.  
Unfortunately, when I tried logging in with a Sugar session it died 
almost immediately.  I tried running "sugar" from the command line and 
this is what I got:

Traceback (most recent call last):
  File "/usr/bin/sugar-shell", line 30, in <module> from main import main
  File "/usr/share/sugar/shell/", line 35, in <module>  import 
  File "/usr/share/sugar/shell/view/", line 38, in <module>  
from view.frame import frame
  File "/usr/share/sugar/shell/view/frame/", line 29, in 
<module>  from view.frame.activitiestray import ActivitiesTray
  File "/usr/share/sugar/shell/view/frame/", line 23, 
in <module>  from import HTray
  File "/usr/lib/python2.5/site-packages/sugar/graphics/", line 
22, in <module>  from import ToolInvoker
  File "/usr/lib/python2.5/site-packages/sugar/graphics/", 
line 924, in <module>  class WidgetInvoker(Invoker):
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gobject/", 
line 40, in __init__cls._install_properties()
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gobject/", 
line 68, in _install_properties " or getter. This is not allowed" % (cls,))
TypeError: GObject subclass <class 
''> defines do_get/set_property and 
it also uses a property which a custom setter or getter. This is not allowed

I had to compile a bunch of stuff from source to get sugar-jhbuild to 
work on 10.2 so i did a "make uninstall" on everything sugar-related I 
compiled.  This had no effect at all on the messages I have attached.  
I'm stumped here and hope you can give me some insight on what is 
happening and how I might go about fixing it.

James Simmons

More information about the Devel mailing list