power consumption after shutdown

quozl at laptop.org quozl at laptop.org
Fri Feb 13 23:56:32 EST 2009


Long ago I did some early measurements of the EC and it was consuming
current while operating.

The operating current has varied slightly according to the firmware
version.  There have been improvements, but I've not measured it
recently.

The symptom you describe is quite normal ... the battery has discharged,
and the state of charge evaluated by the EC shows that charging would be
of benefit.  So it goes yellow.

If you wish to avoid this draining by the EC, and instead rely only on
draining by self-discharge of the battery pack, then remove the pack
from the XO.  Self-discharge rate has a dependency on storage
temperature as well.

If you wish to measure the EC current, a simple way to do it is to
remove the battery pack, and place a current measuring device in series
with the DC cable to the XO.  This gives you a maximum.  The actual
current is smaller, because the DC socket path to the EC has more losses
than the DC battery path.

I did this just now, on a unit running Q2E27, and another running Q2E30,
the current is 24mA at 12.9V powered from a large sealed lead acid
battery with nothing else attached.  Two days of this would be 1.15 amp
hours (Ah).  Three days would be 1.73 Ah.

Assuming 3.1 Ah OLPC CL1 Li-Fe battery, two days should be enough to
bring the state of charge down to about 63%, certainly time for a
charge.

-- 
James Cameron    mailto:quozl at us.netrek.org     http://quozl.netrek.org/


More information about the Devel mailing list