Battery recovery issues

Emiliano Pastorino epastorino at
Tue Apr 28 15:09:33 EDT 2009

Hello everyone,

I'm trying to recover a battery than seems to be broken.
This is what I've done so far:

- I've plugged the battery on an unsecured XO.

- When I run "watch-battery" from the ok prompt, I get a "No battery"

- I tried "see-bstate" and I get an infinite output of "0 1 2 0 1 2 0 1 2 0
1 2...."

- Battery led never flashes.

- If I use a known good battery, I get all the expected results (led turns
on, nice
output from the commands above).

Besides, I tried to use batman.fth, but when I run "fload nand:\batman.fth"
I get
"The file 'nand:\olpc.fth' cannot be opened".
I've downloaded batman.fth from
and placed it in / .

I'm using firmware Q2E35.

Is that battery unrecoverable? How can I tell the difference between a
broken battery and a broken-but-recoverable one?

Any tips?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list