q2e15 and a bricked BTest-2

Jecel Assumpcao Jr jecel at merlintec.com
Tue Sep 9 16:36:20 EDT 2008


About a week ago I attempted the update the firmware on a BTest-2
machine from q2c11 to q2e15. There were no error messages, but after it
shut down the screen no longer turns on. The EC seems to be working
(mostly at least) ok.

The idea was to test SqueakNOS but its boot.fth file uses commands that
were not implemented in q2c11. Attempts to manually use the old commands
to boot resulted in a messed up screen for about a second followed by an
automatic reboot. So I downloaded q2e15 and did the upgrade (the better
was at about 85% rather than completely full). Now pressing the power
button will cause the power led to light up but no others and the screen
remains off. Two very slight clicks can be heard on both speakers every
two seconds. Pressing the power button long enough will make the power
led turn off. I suspected that the download might have been bad and so
downloaded it again using a different web browser, but the result was
bit identical to what I had used in the upgrade.

Plugging the machine into the external power makes the battery led light
up yellow for a few minutes, but then it starts to blink red very
slowly. The battery has to be removed for that to stop. Removing the
external power sometimes causes a lot of noise (from the speakers, I
guess).

I know that newer versions of the OS can't be used on such an old
machine and had expected there to be limits for the firmware too, but
everything I found on the wiki indicated that all versions are
compatible with it (only ATest has limits).

While it is easy for me to make a serial cable to get more details about
what it going on and to flash another version of the firmware, a lack of
time will keep me from doing this in the next few weeks.

-- Jecel



More information about the Devel mailing list