8.2-759 impressions

Douglas Ridgway ridgway at dridgway.com
Sat Sep 6 19:07:41 EDT 2008


I spent a few minutes updating to 8.2-759 and trying things out, and
typed up a few impressions. I haven't investigated anything anywhere
near thoroughly enough to file any issues, but I hope this report is
useful anyway.

Hardware: G1G1 previously upgraded to 703

The update process went okay. There were a few weird errors I didn't
record during the update itself, but it seemed to work anyway. I
updated Activities on first boot as requested. The new updater is
nice. I'd previously had trouble updating the Browse activity from
inside of Browse itself.

General performance (boot and activity launch times) seems improved.

Networking: no longer needs to be told which AP to use, very nice.

Power management: seems much better. I closed it and left it on
unplugged overnight, and was surprised to see a full charge in
morning. From previous experience I'd expected total depletion.

Sugar shell
 I generally like the new interface, especially config.
 Glitches include the appearance of a frame which couldn't be made to
go away without a reboot (condition occurred multiple times), and
duplicate menu items in frame top bar activity hover menus.
 Clicking an already started activity seems to open new instance,
instead of switching to existing one, which is what I would have
expected.
  The task switching (Alt-Tab) interface improved, and Alt-Backtab now
works, happily.

Browse works. Things I tried:
 general web/news:  wikipedia, salon, nyt: okay, but linked  mp3 for
an article failed: error message something like "this movie requires
an MPEG layer 1 decoder which is not installed"
  Phyla PDF from biology links on main browse page, after going
through rigamarole of download, look at journal, launch Reader – looks
okay though
 gmail is mostly usable, as is docs.google.com (incl doc export and
open in Write, and spreadsheet)
 wiki.laptop.org/go/Browse, youtube videos before Adobe Flash install:
viewing these pages froze system
  mylittlepony.com: didn't work even after Adobe Flash install

Record works. I took a still image, and a movie. Ctl-C after selecting
image doesn't copy to clipboard, I needed to use the hover menu.

Pippy
 I think simple easy text examples should be listed higher than fancy
graphics, they are easier for novice programmers to understand. I
believe it used to be this way?
 The examples I tried all worked except for the camera example
("illegal instruction").

Speak, StoryBuilder, and SimCity: all work, but StoryBuilder seems to
be missing sound, and quitting SimCity doesn't seem to kill it.

Write
 Works well enough so that I wrote much of the first draft this review
in it.  I moved a doc to a usb drive, and opened it successfully in
OO.o, including formatting. This didn't work before, so this is a
major improvement. In particular, this can now be used to print. I
also tested bringing an image in. Ctl-V doesn't paste image from
clipboard, needed to drag and drop from frame. It did work, though.
Various glitches include:
 file reopened at different zoom level
 I lost work several times, not sure exactly how, maybe some
interaction with Journal, or Sugar task switching. I was taking notes
in Write while I tested other activities. I eventually gave up and
finished writing on another computer.

I also tried Terminal, TamTamJam, TurtleArt, Paint, Etoys, TuxPaint,
Analyze, and a self-developed camera activity briefly. They all seem
to work as well as before (though Paint was a bit laggy). But Measure,
TuxPaint, and LogViewer didn't launch, and SynthLab crashed after
awhile.

In summary, there are lots of exciting advances, and I hope the
glitches get sorted out.

doug.


More information about the Devel mailing list