Occasional mmc0 timeout on 2.6.25 master kernels

Denver Gingerich denver at ossguy.com
Wed Oct 8 12:34:49 EDT 2008

Hash: SHA1

On Fri, May 2, 2008 at 12:24 PM, Denver Gingerich  wrote:
> On Fri, May 2, 2008 at 12:12 PM, C. Scott Ananian  wrote:
>> On Thu, May 1, 2008 at 10:52 PM, Denver Gingerich  wrote:
>>  > When booting 2.6.25 master kernels (specifically seen on 20080501.2
>>  >  and 20080501.3) from an SD card, the following error occurs every 5th
>>  >  boot or so:
>>  >
>>  >  [ 3.512185] Waiting 2sec before mounting root device...
>>  >  [ 5.574603] VFS: Cannot open root device "mmcblk0p1" or
>>  >  [ 5.577210] Please append a correct "root=" boot option; here are the
>>  >  available partitions:
>>  >  ...
>>  >  [ 5.747213] Kernel panic - not syncing: VFS: Unable to mount root fs
>>  >  on unknown-block(0,0)
>>  >  [13.597220] mmc0: Timeout waiting for hardware interrupt.
>>  >
>>  >  I have never encountered this error using 2.6.22-20071121.7
with over 50 boots.
>>  Does increasing rootdelay help?  ie, is the problem that setting up SD
>>  is now taking (say) 1.5-2.5 seconds instead of 1-2 seconds, and so
>>  sometimes the SD card is not present after the 2 second rootdelay?
> I can give it a shot, but I don't think it will help.
> 2.6.22-20071121.7 always ran fine with rootdelay=1 and when I first
> got the mounting problem on 2.6.25 I increased it to rootdelay=2.  But
> the mounting problems continued after making that change.  The type of
> error (mmc0 timeout) suggests that there are communication problems
> with the SD controller that would prevent the kernel from finding the
> partition table, even after waiting 10 seconds (the apparent length of
> the timeout given the timestamps).

This issue remains present on the 2.6.26-20080731.1 kernel (available
from http://dev.laptop.org/~dilinger/master/).  However, it is
slightly different.  With the new kernel, there is no list of
available partitions following the "here are the available partitions"
message.  Additionally, there is no "mmc0: Timeout waiting for
hardware interrupt." message.

I tried the 2.6.26-20080731.1 kernel with rootdelay=1 and
rootdelay=30; both produced the same result.

Should I be reporting this to a bug tracking system?  Or should I
refrain from doing so since this is a development kernel?

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: http://getfiregpg.org


More information about the Devel mailing list