[PATCH stable] Separate multicast configuration for mesh and wlan interfaces.

Andres Salomon dilinger at queued.net
Tue May 13 17:12:01 EDT 2008


On Tue, 13 May 2008 12:30:53 -0700
Andrew Morton <akpm at linux-foundation.org> wrote:

> On Tue, 13 May 2008 13:20:19 -0400
> Andres Salomon <dilinger at queued.net> wrote:
> 
> > On Tue, 13 May 2008 15:45:39 +0100
> > David Woodhouse <dwmw2 at infradead.org> wrote:
> > 
> > > On Tue, 2008-05-13 at 15:38 +0100, David Woodhouse wrote:
> > > > 
> > > > And even without that, it doesn't seem to do the right thing.
> > > > Set IFF_PROMISC mode on one interface, then on the other, then
> > > > clear it on the first.... it should remain set in hardware. And
> > > > AFAICT it doesn't.
> > > > 
> > > > I'll see if I can make it work....
> > > 
> > > Hm, a single cup of tea mostly achieves that; sorry :)
> > > 
> > > I was missing the fact that priv->packetfilter[] is now an array.
> > > It got a bit clearer after I reformatted it to stop trying to fit
> > > in 80 columns. Sometimes the code just doesn't fit; it's painful
> > > to try to make it.
> > > 
> > 
> > Gosh, I sure wish you, Andrew, checkpatch.pl, and Ingo[0] were all
> > on the same page regarding that.. it would sure make my life easier.
> > 
> 
> David is off in his own little world on this and can be safely
> ignored.
> 
> Meanwhile the rest of us are forced to stare at crocks of shit like
> http://userweb.kernel.org/~akpm/x.jpg, wondering who hates us and why.
> 

And Ingo's comments?

While I normally agree w/ breaking long lines up, when the entire line
is a string, I find it a large pain to break it up.  I'm curious if
people would be against checkpatch.pl not complaining about lines >80
chars if the line contains a quoted string.

Actually, I wonder if the following patch would be acceptable (ignoring
the fact that it fails checkpatch.pl, of course :)





From: Andres Salomon <dilinger at debian.org>
Subject: [PATCH] checkpatch: make the 80-char-line check slightly more lax; allow long strings

Currently, the 80-char-line check in checkpatch.pl doesn't allow the following:

+       printk(KERN_WARNING
+                       "one two three fooooooooooooooooooooooooooooooooooooooooooooooo\n");

Instead, one must break the string up into multiple lines, like so:

+       printk(KERN_WARNING
+                       "one two three "
+                       "fooooooooooooooooooooooooooooooooooooooooooooooo\n");

This is not really easier to read, and as Ingo has pointed out, it makes
life harder for people grepping for kernel messages.  Of course, we don't
want to allow gratuitously long printk lines if they're unnecessary.

This patch allows a line to be > 80 chars if it contains only a string and
some extra stuff at the end (',', ';', or ')').  Thus,

+ printk(KERN_WARNING
+                       "one two three fooooooooooooooooooooooooooooooooooooooooooooooo\n");

and

+       printk(KERN_WARNING
+                       "one two three fooooooooooooooooooooooooooooooooooooooooo\n",
+                       xyz);

are allowed, but

+ printk(KERN_WARNING "one two three fooooooooooooooooooooooooooooooooooooooooooooooo\n");

and

+       printk(KERN_WARNING
+                       "one two three foooooooooooooooooooooooooooooooooooooo\n", xyz);

are not.

Signed-off-by: Andres Salomon <dilinger at debian.org>
---
 scripts/checkpatch.pl |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index b6bbbcd..00f3d05 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -1117,7 +1117,7 @@ sub process {
 			ERROR("trailing whitespace\n" . $herevet);
 		}
 #80 column limit
-		if ($line =~ /^\+/ && !($prevrawline=~/\/\*\*/) && $length > 80) {
+		if ($line =~ /^\+/ && !($prevrawline=~/\/\*\*/) && !($line =~ /^\+\s*"/ && $line =~ /"[);,\s]*$/) && $length > 80) {
 			WARN("line over 80 characters\n" . $herecurr);
 		}
 
-- 
1.5.5.1




More information about the Devel mailing list