Touch pad

David Leeming leeming at
Wed Jul 30 16:28:56 EDT 2008

You wrote:

We (the techteam) have some questions:

 - Are there any XOs for which mouse performance is worse since the
   kernel upgrade?
 - What are the average environmental conditions (humidity level, dust,
   temperature) when you are testing the new driver?

Please answer at your leisure.


My answer:

So far, I have successfully installed the updated kernel on my B4s but not
on the secure G1G1s as that requires a different approach that I have not
gotten my head around.

I used the updated B4s as my "teaching laptops" at the Batuna trial (see
Youtube link at I did
notice some misbehaviour. I can't quantify it and it seemed less of a
problem than before. As far as I could tell, the cursor sometimes became
very sluggish but did not jump around as before when the issue was observed.
The 4 finger salute to recalibrate the touchpad worked well. So my
impression is that there is still some misbehaviour of the touchpad but it
is improved. This is however based on only a few days experience.

This was in the Solomon Islands, where it is often above 90% humidity and
32-24 degrees C. Very bad conditions for the touch pad!

David Leeming
OLPC Coordinator, SPC and Technical Advisor, People First Network
Honiara, Solomon Islands

-----Original Message-----
From: Erik Garrison [mailto:erik.garrison at] On Behalf Of Erik
Sent: Thursday, 17 July 2008 10:49 a.m.
To: David Leeming
Cc: richard at; devel at; greg at
Subject: Re: Touch pad




On Thu, Jul 17, 2008 at 07:49:06AM +1100, David Leeming wrote:
> Hi Richard, sorry I am a bit slow with Linux :) can you say where to do
> ls -l and uname -a? Just need a bit of clarification on how to check it is
> installed.
> By the way, I DID notice a bit of jumping cursor behaviour after the
> on a couple of XOs. The 4-finger salute helped a lot. Too early to make
> conclusions, as maybe it wasn't installed properly.
> David Leeming
> OLPC Coordinator, SPC and Technical Advisor, People First Network
> Honiara, Solomon Islands
> -----Original Message-----
> From: Richard Smith [mailto:smithbone at] On Behalf Of Richard A.
> Smith
> Sent: Thursday, 17 July 2008 2:43 a.m.
> To: David Leeming
> Cc: pgf at; devel at
> Subject: Re: Touch pad
> David Leeming wrote:
> > The cp command gave a string of complaints that the source and
> > files "are the same file". I am therefore unsure if it worked
> > as per the comment below on the wiki page. However after a reboot the
> > touchpad still works...
> > 
> >>>>> If you omit the -a in the above recipe, the vmlinuz symlink will not
> be
> > updated correctly
> nod.  There's a lot of noise when you do the copy.  A quick ls -l to 
> verify that the bzImage symlink now points at your new kernel can be 
> used if you have doubts.  And then uname -a when you reboot to verify 
> the commit ID matches what you think you installed.  Always a good 
> check.  I've installed the wrong .rpm a few times.
> -- 
> Richard Smith  <richard at>
> One Laptop Per Child
> _______________________________________________
> Devel mailing list
> Devel at

More information about the Devel mailing list