[sugar] Write needs your help (was Re: Programming environments on the XO)

Edward Cherlin echerlin at gmail.com
Thu Jul 17 15:44:29 EDT 2008


On Thu, Jul 17, 2008 at 12:10 PM, Tomeu Vizoso <tomeu at tomeuvizoso.net> wrote:
> On Thu, Jul 17, 2008 at 8:58 PM, Edward Cherlin <echerlin at gmail.com> wrote:
>> On Thu, Jul 17, 2008 at 1:16 AM, Tomeu Vizoso <tomeu at tomeuvizoso.net> wrote:
>>
>>> The abi devs have also asked for help in testing Write with non-latin
>>> scripts, this is something of high importance for OLPC.
>>
>> I can do that. OK, Cyrillic works. I just entered every key on the
>> layout, upper and lower case. I'll get you lots more writing systems
>> later today. I am _not_ going to test every Chinese character %-[.
>
> Which version are you testing? I would say that downloading an Abiword
> binary 2.6.4 from abisource.com may be best, as that's the version
> that I hope we'll use in Write for 8.2.0.

I'll see about that. Right now I am using Write 55-0ubuntu1, which
doesn't say what version it is in those terms.
http://abisource.com/wiki/Install_on_Ubuntu is out of date. It says
2.4.6 was in Gutsy, and that 2.6 should have been in Hardy, but what I
see is Abiword 2.4.6-3ubuntu3. What actually happened?

But is the question testing stock Abiword or Write? Or do you want me
to do both?

> I hope we'll be able to
> update joyride with 2.6.4 soon so the Write there will be definitely
> the software we'll be shipping.

I'll install joyride in qemu when 2.6.4 is ready and give it a go.
Remind me when the time comes.

> Thanks,
>
> Tomeu

-- 
Edward Cherlin
End Poverty at a Profit by teaching children business
http://www.EarthTreasury.org/
"The best way to predict the future is to invent it."--Alan Kay


More information about the Devel mailing list