my XO has difficulty with f9

C. Scott Ananian cscott at
Tue Jul 1 11:24:44 EDT 2008

On Tue, Jul 1, 2008 at 9:52 AM, Mikus Grinbergs <mikus at> wrote:
> Scott, thank you for your response.  By saying "after anacron, X is supposed
> to start", you've clarified things for me.  My current thinking is that X
> was not starting for me, and that I may have caused that by (at that first
> boot) making some sort of change that worked with f7 but not with f9 (I
> install some rpms, etc.).

That seems likely, but the olpc-update system should ensure that
you've got a clean system (no extra RPMs) when you revert.  I would
hope that even if X doesn't start (especially if X doesn't start) you
can still get a console and/or use alt-boot (hold down 'O' at boot) to
fix things.  That's the whole point, after all.

>> and tell us exactly what the last message is
> I believe I gave adequate information in my post.  When I use the 'check'
> key, the last message is 'Starting anacron'.  When instead I "just switch to
> the console", some additional messages show up after the 'Starting anacron'
> message (each message contains a header, then 'msh0: link becomes ready').
> [By the way, I have no wireless at my house - the XO radio has nothing it
> can talk to.] I've waited 10+ minutes for additional messages - none came.

Hmm, I was hoping that when you said "no more messages" what you means
was, "X started, and showed various things before hanging, but there
was nothing more written to the console during that process".  It
seems like you're hanging at X startup.  Do you remember what RPMs you
might have installed to make this happen?

> I was concerned about randomly seeing "jffs2 checksum error" messages on the
> text console (but not as the last message).  By saying "X is supposed to

Mostly harmless.

> With apologies, I think I'll wait a bit.  Didn't like having to do a
> complete reflash to get back to a working f7 system - so I'll hold off on f9

Did you try alt-boot (holding down the "O" gamepad key during boot)?
Did it not work?

> until I again get impatient to see "how well does it work?".  f9 did not see
> removable USB storage devices (except my "permanent" SD card), and there are
> times when I need to use two of them on my XO (in addition to my USB
> keyboard and USB mouse).  The current Joyride (2089) does *not* as yet
> provide me the "complete" working environment that I am used to with
> Update.1 or Joyride-2056.

Yes, this is true. and looks like the two biggest blockers
to more people trying joyride right now.

I *think* that USB/SD not being mounted when you are looking at the
console (as opposed to X/Sugar) is a "feature".  Do folks think this
needs to be fixed?

 ( )

More information about the Devel mailing list