Cmap tools (with image customization cross over)

Greg Smith gregsmitholpc at
Tue Dec 23 15:35:53 EST 2008

Hi Bert,

Thanks. It was actually right click for me but that did it.

I installed the Cmap tools from within the X activity and it mostly worked.

A few oddities in the X activity like the arrow keys not working but 
nothing fatal.

I'll follow up with the Cmap people and see if they can move it ahead 
some more.


Here's a good use case for the "image customization" feature. To install 
Cmap, I open the X activity, downloaded a zip, then unpacked it which 
created a bin file. I made that executable and ran it which launched an 
installer which installed Java and some other stuff into a directory I 
chose (data). I also assume they would want to tweak the X activity 
initrc file to make it launch Cmap automatically. The whole thing is 
within a Rainbow instance but I believe its re-usable if its in the data 

Would your customization stick strategy allow me to make this whole 
thing part of an image installable on many XOs as described?


Greg S

Bert Freudenberg wrote:
> Click to bring up a menu and open a terminal.
> Alternatively, edit the ".xinitrc" file to auto-launch any X 
> applications you want started ("xterm &" is a common choice) before 
> executing the window manager. This is also how you would bundle and 
> launch a regular X app like cmap.
> - Bert -
> On 23.12.2008, at 16:34, Greg Smith wrote:
>> Hi Michael and Bert,
>> It got quiet enough that I had a chance to try this myself.
>> I tried installing and running the X activity and I tried following 
>> the instructions here: 
>> In both cases I got a gray screen with a "bar" showing "Workspace" 
>> with two triangles next to it (left and right facing) on the left side 
>> of the bar and the time with the same triangles on the right side.
>> I didn't see my pointer in the Hackfest version but I did in the X 
>> window version. In both cases I didn't see any place to enter text 
>> (e.g. a window). Am I missing something?
>> I was hoping to get an X window with a prompt so I could install CMap 
>> tools from there.
>> Any suggestions appreciated.
>> Thanks,
>> Greg S
>> Greg Smith wrote:
>>> Hi All,
>>> Picking up this old thread 
>>> (
>>> I want to move this forward again.
>>> There is a beta version of a smaller Linux implementation of CMap 
>>> tools now. Download it from here:
>>> Does anyone have time to try running this inside of the X windows 
>>> activity mentioned below?
>>> While we have some traction on other concept map tools (thanks Tomeu 
>>> for Labrynth), CMap is "incumbent" in a number of countries and I 
>>> want to figure out how close we are to supporting it. It will affect 
>>> our ability to get XOs and Sugar in to more schools systems so its 
>>> certainly valuable work.
>>> Let me know if anyone has a chance to try this out and document what 
>>> it will take to make it work.
>>> Thanks,
>>> Greg S
>>> *************
>>> On Thu, Sep 4, 2008 at 4:00 PM, Bert Freudenberg <bert at 
>>>> wrote:
>>> >
>>> > Am 04.09.2008 um 01:06 schrieb Michael Stone:
>>> >
>>> >> On Wed, Sep 03, 2008 at 05:33:28PM -0400, Greg Smith wrote:
>>> >>> Has anyone tried making the activity which is X-windows and inside
>>> >>> which
>>> >>> other activities can run?
>>> >>
>>> >> [1] and [2] seem apropos.
>>> >>
>>> >> Michael
>>> >>
>>> >> [1]:
>>> >> [2]: 
>>> >
>>> > I couldn't resist making an activity for that:
>>> >
>>> >
>>> Anybody has any idea about how to make xephyr use the clipboard of the
>>> external X server? DND may be even harder.
>>> Regards,
>>> Tomeu

More information about the Devel mailing list