clean installation of 643.

Alexander M. Latham Alexander.M.Latham at Dartmouth.EDU
Wed Nov 28 12:24:43 EST 2007

--- Yoshiki Ohshima wrote:
I tried to do clean install of 643 and it failed.  Actually, it worked
for the first time.  Then, I realized that I forgot to put Q2D05
firmware on my USB memory.  So I put the .rom file and tried the clean
installation again.  Then during the boot process I got:

**** Restoring from backup ****
tar: Short read
Traceback (most recent call last):
  File "/init", line 110, in <module>
  File "/init", line 87, in backup_or_restore
  File "/init", line 77, in do_restore
    safe_sh("tar -xz -f " + backup_file + " -C /restore")
  File "/", line 26, in safe_sh
    raise RuntimeError("Command exited with non-zero exit status.")

-- Yoshiki
--- end of quote ---

In the future, if you're only updating the ofw, you should just get to the ok prompt and type:  ok flash path_to_file

Also, after the firmware is upgraded, it reboots the machine, which would then lead the machine into trying to do an upgrade instead of a clean install if you don't hold the square key. That is probably why it created a backup and tried to restore from it. This means there may be some issues with the auto-reinstallation process, which should be looked into.

- AlexL

More information about the Devel mailing list