Build 385 quemu emulation on Mac OS X

Julius Lucks lucks at
Sat Apr 7 22:36:20 EDT 2007

Hi All,

This is the first time I have tried XO emulation, and I am having a  
bit of trouble.  I have tried to follow the instructions at

In particular, I downloaded and installed version 0.8.1.a35  
from .  I then downloaded the XO image


STABLE-BUILD/devel_ext3/ .

After unzipping the image, I configured to use the image  
according to the instructions on the wiki page.  However, when  
configuring the advanced settings with:

 > Advanced - QEMU Arguments: type "-redir tcp:2222::22" (without  

as instructed by the wiki, would not start from the disk image  
and instead gave the cryptic warning "Syntax Error" no matter what I  
tried.  Removing this line from the advanced arguments, did  
boot up from the disk image, but I did not get a GRUB screen as the  
wiki said.  Following the steps listed on 
Sugar_Instructions, what happened instead of seeing the GRUB loader  
was the linux bootup.  After that, it asked me for a login name that  
would not except anything but the name 'root' with no password.  I  
got a terminal as root then, but I was not able to proceed with  
seeing Sugar any further.

My platform details are:
12" Aluminum G4 1.33 GHz
756 MB Memory
OS X version 10.4.8

If anyone has any hints as to what I might be doing wrong, I would be  
very appreciative!

Another question I have concerns keyboard layout.  I have my OS X  
keyboard in the Dvorak configuration and it looks like this is not  
setup by default when emulating XO with quemu.  How do I use a Dvorak  
layout with emulation?

Once again, I appreciate your time and help.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list