[PATCH v2] Re: Battery class driver.

Pavel Machek pavel at ucw.cz
Sat Oct 28 17:05:09 EDT 2006

On Sat 2006-10-28 15:53:56, David Zeuthen wrote:
> On Sat, 2006-10-28 at 18:55 +0000, Pavel Machek wrote:
> > Bad idea... I bet someone will just ignore the units part, because all
> > the machines he seen had mW there. 
> Sure, user space can do silly things. Just ask davej. Let's try to
> assume they don't.
> > Just put it into the name:
> > 
> > power_avg_mV
> Bad idea... it means user space will have to try to open different files
> and what happens when someone introduces a new unit? Ideally I'd like
> the unit to be part of the payload of the sysfs file. Second to that I
> think having the unit in a separate file is preferable.

Introducing new unit *should* be hard. You know, when you introduce
new unit, you automatically break all the userspace.

Having separate files is actually a *feature*. It allows you to
introduce new units while providing backwards compatibility.

Imagine going from mV to uV... With voltage_mV, you can have both
voltage_mV and voltage_uV. In your system, you'd have to change value
from mV to uV, breaking all the userspace....
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

More information about the Devel mailing list