[olpc-help] Sugar GUI applications (activities) won't start

Andrew andrew2006 at flight.us
Tue Mar 25 21:45:32 EDT 2008

>I believe also many activities can also run from terminal, which has the >benefits of showing error output of situations.  Hopefully, the messages >will assist in pointing in the right direction of the sugar based >conflict.

I have googled, scoured the wiki and bashed my head a bit, but can't find the command to launch a sugar activity from the command line.

The closest i've found is:

              sugar-activity Analyze.activity 

(or without that long extension)

but I always get:
SUGAR_BUNDLE_PATH is not defined in the environment

I've googled for SUGAR_BUNDLE_PATH but found nothing.
I this path really off in my system, or is the problem something else.

man pages are nonexistant. I even yum-installed mlocate to try to "locate" stuff, but no cigar.

Please help!

On Tue, Mar 25, 2008 at 11:54 AM, Steve Holton <sph0lt0n at gmail.com> wrote:
Hi Andrew-

There was a problem seen in the 650 loads where the flash would
fill-up completely and prevent activities from starting.
-   http://wiki.laptop.org/go/Support_FAQ#After_working_properly_for_a_while.2C_activities_won.27t_load

Are you running the 650 release?

On Tue, Mar 25, 2008 at 2:22 PM, Andrew <andrew2006 at flight.us> wrote:
> All worked well for a couple of weeks in our new XO laptop, but i have been installing and running extra apps and changed the DISPLAY variable and added to /etc/hosts a few times.  (currently
>  i have yum-installed various apps, including gcc, wvdial, emacs, lynx
>  yesterday the GUI apps appear to have stopped loading. When invoked from Desktop bottom row of icons, the icons appear in the circle but their status is just "Starting..." ad infinitem, and they just hang in that state and don't load.  Rebooting doesn't seem to help.
>  The "Terminal Activity" and lynx _do_ load, which suggests to me that the problem is with the GUI apps only.
>  HOWEVER, it seems to be SUGAR apps, in particular, because when I run  emacs GUI, as user olpc and with DISPLAY=:0 , emacs GUI does come up correctly.
>  Or maybe i'm barking up the wrong tree, entirely?
>  /etc/hosts currently has:
> xo-14-4F-01.localdomain xo-14-4F-01 localhost
> localhost.localdomain localhost
>      schoolserver
>  TIA
>  Andrew
>  _______________________________________________
>  community-support mailing list
>  community-support at lists.laptop.org
>  http://lists.laptop.org/listinfo/community-support

Steve Holton
sph0lt0n at gmail.com

community-support mailing list
community-support at lists.laptop.org

More information about the community-support mailing list