#12593 NORM 13.1.0: Unable to restart XO-4 from Sugar

Zarro Boogs per Child bugtracker at laptop.org
Thu Mar 7 11:38:29 EST 2013

#12593: Unable to restart XO-4 from Sugar
           Reporter:  wad       |       Owner:  erikos                           
               Type:  defect    |      Status:  new                              
           Priority:  normal    |   Milestone:  13.1.0                           
          Component:  sugar     |     Version:  Development build as of this date
         Resolution:            |    Keywords:  XO-4, restart                    
        Next_action:  diagnose  |    Verified:  0                                
Deployment_affected:            |   Blockedby:                                   
           Blocking:            |  

Comment(by manuq):

 Replying to [comment:1 wad]:
 > After trying to restart twice, I quit Record.  I then tried going back
 to browse, and the laptop went to a gray screen and a spinning cursor icon
 for minutes.
 > I haven't been able to reproduce this, so the state of Browse was
 probably very relevant.

 Indeed it was.  Just happened to me too.

  - I had Browse opened for a while
  - Went to the frame, clicked "Restart" -> nothing happened
  - (Collected logs and tried things in the console)
  - Stopped Browse
  - Clicked "Restart" -> again the XO didn't reboot, but a grey screen with
 a generic icon appeared, and whose palette is the same as the recently
 closed Browse (screenshot attached)
  - Went to the console, I can see Browse process still there
  - Killed Browse process
  - Pressed "Restart" again -> this time the XO reboots

 Browse log has python traceback:

 Traceback (most recent call last):
   File "/usr/bin/sugar-activity", line 160, in <module>
   File "/usr/bin/sugar-activity", line 147, in main
   File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in
     return self._proxy_method(*args, **keywords)
   File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in
   File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in
     message, timeout)
 dbus.exceptions.DBusException: org.freedesktop.DBus.Python.RuntimeError:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in
     retval = candidate_method(self, *args, **keywords)
   File "/usr/bin/sugar-activity", line 68, in create
     create_activity_instance(self.constructor, handle)
   File "/usr/bin/sugar-activity", line 42, in create_activity_instance
     activity = constructor(handle)
   File "/home/olpc/Activities/Browse.activity/webactivity.py", line 153,
 in __init__
     activity.Activity.__init__(self, handle)
   File "/usr/lib/python2.7/site-packages/sugar3/activity/activity.py",
 line 356, in __init__
   File "/usr/lib/python2.7/site-
 packages/sugar3/presence/presenceservice.py", line 75, in get_activity
     raise RuntimeError('Activities can only access their own'
 RuntimeError: Activities can only access their own shared instance

 1362662859.461691 DEBUG root: _cleanup_temp_files
 Exited with status 1, pid 2727 data (None, <open file '<fdopen>', mode 'w'
 at 0x17f91d8>, '6e32129891aa06c58c4c35e28e91086ff3f3ef81')

Ticket URL: <http://dev.laptop.org/ticket/12593#comment:6>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list