#12652 NORM 13.2.0: Can't change Sugar zoom levels in first boot

Zarro Boogs per Child bugtracker at laptop.org
Wed Apr 10 16:47:31 EDT 2013

#12652: Can't change Sugar zoom levels in first boot
 Reporter:  manuq   |                 Owner:  erikos       
     Type:  defect  |                Status:  new          
 Priority:  normal  |             Milestone:  13.2.0       
Component:  sugar   |               Version:  not specified
 Keywords:          |           Next_action:  reproduce    
 Verified:  0       |   Deployment_affected:               
Blockedby:          |              Blocking:               
 This was reported for 13.2.0 os2 XO-1 and it just happened to me in os3

 The first thing I tried after boot was going to the neighborhood to
 connect to an AP.  I tried with the button in the top-left corner of the
 frame.  As nothing happened, I tried the other zoom buttons and the F1-F3
 keys.  Nothing heppened too.  After the Journal was displayed, the problem
 went away.  I wasn't able to reproduce after reboo.  The shell log has a
 clear traceback:

 Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/jarabe/frame/zoomtoolbar.py",
 line 83, in __level_clicked_cb
   File "/usr/lib/python2.7/site-packages/jarabe/model/shell.py", line 407,
 in set_zoom_level
     active_window_type = screen.get_active_window().get_type_hint()
 AttributeError: 'NoneType' object has no attribute 'get_type_hint'

 I'm attaching the complete log.

Ticket URL: <http://dev.laptop.org/ticket/12652>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list