#10492 LOW F14: idle sleep/suspend fails when booting from external devices

Zarro Boogs per Child bugtracker at laptop.org
Fri Dec 3 17:19:22 EST 2010

#10492: idle sleep/suspend fails when booting from external devices
           Reporter:  mavrothal               |       Owner:  pgf                              
               Type:  defect                  |      Status:  new                              
           Priority:  low                     |   Milestone:  F14                              
          Component:  power manager (powerd)  |     Version:  Development build as of this date
         Resolution:                          |    Keywords:  os3, XO-1                        
        Next_action:  reproduce               |    Verified:  0                                
Deployment_affected:  none                    |   Blockedby:                                   
           Blocking:                          |  

Comment(by mavrothal):

 50some reboots later the problem stands[[BR]]
 However, what is really triggers it is the inactivation of prettyboot that
 both my external-device olpc.fth do. I assume you have commented out
 "visible" in the olpc.fth of  "A single bootloader for both XO-1 and
 XO-1.5". If you do, idle suspend works fine even if you boot from the USB
 Actually you do not need to boot from an external device to reproduce the
 bug. Booting a virgin  os4 with the checkmark game-key pressed to
 inactivate prettyboot, will do the trick.

Ticket URL: <http://dev.laptop.org/ticket/10492#comment:3>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list