#9765 LOW 1.5-sof: frame battery icon lags charging initiation

Zarro Boogs per Child bugtracker at laptop.org
Thu Apr 22 19:37:36 EDT 2010

#9765: frame battery icon lags charging initiation
           Reporter:  mikus     |       Owner:  pgf                              
               Type:  defect    |      Status:  new                              
           Priority:  low       |   Milestone:  1.5-software-later               
          Component:  kernel    |     Version:  Development build as of this date
         Resolution:            |    Keywords:                                   
        Next_action:  diagnose  |    Verified:  0                                
Deployment_affected:            |   Blockedby:                                   
           Blocking:            |  

Comment(by Quozl):

 Another experience of ''when battery does not need charging, the frame
 status is inconsistent with battery LED''.

 A laptop running os119 with 42% remaining battery and no external power
 was suspended by closing lid.  The battery indicator showed black.

 An hour or two later it was connected to external power but left closed.
 The battery indicator showed orange.

 The next day, roughly ten hours later, the battery indicator was green,
 and the laptop was opened.

 The battery status display in the frame showed "1:11 remaining" and "42%".
 It remained in that state despite the battery capacity being 97%,
 according to /sys/devices/platform/olpc-battery.0/power_supply/olpc-

Ticket URL: <http://dev.laptop.org/ticket/9765#comment:26>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list