#9688 NORM 1.5-F11: terrible SD write performance

Zarro Boogs per Child bugtracker at laptop.org
Tue Nov 17 12:08:04 EST 2009

#9688: terrible SD write performance
           Reporter:  dsd       |       Owner:  wad          
               Type:  defect    |      Status:  new          
           Priority:  normal    |   Milestone:  1.5-F11      
          Component:  hardware  |     Version:  not specified
         Resolution:            |    Keywords:               
        Next_action:  diagnose  |    Verified:  0            
Deployment_affected:            |   Blockedby:               
           Blocking:            |  

Comment(by dsd):

 My simple test application seems to reproduce the issue. It would be
 interesting for other people to try it. Note that it will probably destroy
 your filesystem.

 For some reason, in the test app some of the seeks fail and it doesn't try
 that particular write, but the other ones show the issue.

 As you can see from the attachments above I also moved the SD card over to
 my main laptop and reproduced the issue. Perhaps this SD card just

 There is a frightening correlation between fast and slow sectors on all of
 the above tests. For example, sector 2416648 always seems to be fast, and
 sector 2400280 always seems to be slow. I also noticed a frightening
 correlation between fast and slow sectors when I (separately) repeated the
 test on a 2nd SD card, this one from a different manufacturer
 (Transcend)... !?

Ticket URL: <http://dev.laptop.org/ticket/9688#comment:1>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list