#8479 NORM Not Tri: non-unique default document naming is confusing
Zarro Boogs per Child
bugtracker at laptop.org
Sat Sep 13 20:22:51 EDT 2008
#8479: non-unique default document naming is confusing
--------------------+-------------------------------------------------------
Reporter: kevix | Owner: marco
Type: defect | Status: new
Priority: normal | Milestone: Not Triaged
Component: sugar | Version: not specified
Keywords: | Next_action: never set
Verified: 0 | Blockedby:
Blocking: |
--------------------+-------------------------------------------------------
This seem to be present in all version of Sugar so far (I am using
8.2-759)
(python?) activities have a default naming scheme ("$ACTIVITYNAME
activity") This leads to 100 entries in the journal with the same name.
Which one do I want to read or delete? I can't tell. I could rename each
one but I may not have time. So one solution is to give them unique names.
Maybe 'Chat Activity $EPOCH_SECONDS', 'Write Activity $UUIDGEN' like the
journal? Or 'Terminal $DATE' ? If you have 2 saves in less than a seconds,
you may get 2 titles with the same name. I guess avoid Month or Day as it
may need to be translated or would it use gettext? Maybe a universal
counter that only increment?
I tried this in /usr/lib/python2.5/site-
packages/sugar/activity/activity.py near line 553:
uniquename = commands.getoutput("date +%s")
uniquename = commands.getoutput("date +%N")
uniquename = commands.getoutput("uuidgen")
uniquename = commands.getoutput("date --rfc-3339=ns")
title = _('%s Activity %s') % (get_bundle_name(), uniquename)
But need to add:
import commands
near the top of the file.
[thanks to mstone for the hint]
--
Ticket URL: <http://dev.laptop.org/ticket/8479>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system
More information about the Bugs
mailing list