#8433 HIGH Not Tri: Recently, yum install fails during the checking of package GPG keys.

Zarro Boogs per Child bugtracker at laptop.org
Fri Sep 12 18:33:00 EDT 2008

#8433: Recently, yum install fails during the checking of package GPG keys.
   Reporter:  mikus                |       Owner:  cscott       
       Type:  defect               |      Status:  new          
   Priority:  high                 |   Milestone:  Not Triaged  
  Component:  not assigned         |     Version:  not specified
 Resolution:                       |    Keywords:  polish:8.2.0 
Next_action:  approve for release  |    Verified:  0            
  Blockedby:                       |    Blocking:               
Changes (by garycmartin):

 * cc: garycmartin (added)


 Hmmm, after several attempts was not able to install "git" onto an XO
 joyride-2423 here via yum (planning to package a new version of Moon over
 the weekend, and need XO tools to do all the manifest stuff correctly).
 Then tried "yum install patch" and it worked, so tried "git" again,
 failing with the below error. Then tried yum installing "vim" and it
 worked fine. Gave "yum install git" one more try and this time it
 installed successfully! I thought package dependencies were meant to avoid
 such things (I'm used to working with aptitude and/or apt-get from the deb
 side of things)?

 --- snip ---
 Total size: 18 M
 Is this ok [y/N]: y
 Downloading Packages:
 warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID
 Importing GPG key 0x4F2A6FD2 "Fedora Project <fedora at redhat.com>" from
 Is this ok [y/N]: y
 Public key for git- is not installed

Ticket URL: <http://dev.laptop.org/ticket/8433#comment:5>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system

More information about the Bugs mailing list