#6063 NORM Never A: problem saving a picture from xo into USB stick

Zarro Boogs per Child bugtracker at laptop.org
Thu Jan 17 07:42:59 EST 2008

#6063: problem  saving a picture from xo into USB stick
 Reporter:  walter     |       Owner:  tomeu         
     Type:  defect     |      Status:  new           
 Priority:  normal     |   Milestone:  Never Assigned
Component:  datastore  |     Version:                
 Keywords:             |    Verified:  0             
 Blocking:             |   Blockedby:                
 Bug report from a Build 650 user (as transcribed in the wiki)—Note that
 just pictures from Record don't transfer; other files do transfer.

 I tried to save pictures from my XO in USB stick. My USB now contain a
 folder .olpc.store. And there is no picture in that folder. How shall I
 proceed? Thanx

     When you insert a USB stick in the XO, its contents are indexed so
 that it can be used by the Journal. You can copy files from your Journal
 to the USB stick by dragging them onto the the USB icon that shows up at
 the bottom of the Journal screen. You can view the contents of the USB
 stick from the Journal by clicking on USB icon. You can unmount the USB
 stick from the menu that appears when you hover over the icon. Please
 refer to http://laptop.org/en/laptop/start/journal.shtml --Walter 17:36,
 27 December 2007 (EST)

 Thanx - But my problem is not saving to the USB stick. i already did that
 and my pictures ARE in the USB. I tried ubuntu and i can't open it in my
 laptop(not the xo). But i can see the pictures from the usb on the xo. how
 shall i get the pictures on my laptop?

     I'm sure how to reproduce this bug. Have you tried using a factory
 "fresh" USB key? In the meanwhile, if you have network access, you can
 upload your pictures from the Browse activity, e.g., uploading attachments
 in gmail, etc. --Walter 08:43, 3 January 2008 (EST)

 Walter: thank you , yes my USB is fine. i open a drawing i made in my xo
 on my non-xo laptop(using the same USB). The problem is i can't do the
 same with the pictures.

     This really is interesting. We've never seen this bug in our testing.
 I'll file a bug report. In the meantime, may I suggest that you try doing
 an upgrade to Build 653? There were a few—seemingly unrelated—Journal
 fixes in that upgrade. Maybe it will make a difference. (See Olpc-update).
 --Walter 07:40, 17 January 2008 (EST)

Ticket URL: <http://dev.laptop.org/ticket/6063>
One Laptop Per Child <http://dev.laptop.org>
OLPC bug tracking system

More information about the Bugs mailing list