#2866 HIGH 8.2.0 (: Network Manager GUI doesn't report success or failure
Zarro Boogs per Child
bugtracker at laptop.org
Tue Aug 26 13:39:49 EDT 2008
#2866: Network Manager GUI doesn't report success or failure
----------------------+-----------------------------------------------------
Reporter: gnu | Owner: mtd
Type: defect | Status: new
Priority: high | Milestone: 8.2.0 (was Update.2)
Component: sugar | Version: Development build as of this date
Resolution: | Keywords: 8.2.0:? 9.1.0:+ polish:8.2.0 r-
Next_action: code | Verified: 0
Blockedby: | Blocking: 3993, 6995
----------------------+-----------------------------------------------------
Changes (by tomeu):
* keywords: 8.2.0:? 9.1.0:+ polish:8.2.0 r? => 8.2.0:? 9.1.0:+
polish:8.2.0 r-
Comment:
0001--2866-add-IP-address-to-wireless-ap-palettes.patch
{{{
'ip-changed': (gobject.SIGNAL_RUN_FIRST,
gobject.TYPE_NONE, ([])),
}}}
Any reason why this isn't a property like what you have done in
model/devices/network/mesh.py?
{{{
def _padded(child, xalign=0, yalign=0.5):
}}}
I'm not sure if we have any benefit from having funcs local to methods, as
we should strive to write focused classes with few methods (a dozen max?).
Thus perhaps in sake of keeping things simple we should refrain from using
local funcs and just use regular private methods? This is just my opinion,
not sure if it's shared by anyone else here.
{{{
ip_address_text = "%s: %s" % (_("IP address"), ip_address)
}}}
Is this correct for all languages? Don't exist languages that would use a
symbol different to ':' or have different conventions about spaces, word
positions, etc? I would have done it like this:
{{{
ip_address_text = _("IP address: %s") % ip_address
}}}
so that translators have more choice about how to translate it.
And I prefer to use ' instead of " because find it's more readable, but
again it's my personal preference.
{{{
model.connect('notify::ip-address', self._ip_address_changed_cb)
}}}
Just in case, we make signal handlers really private:
{{{
self.__ip_address_changed_cb
}}}
Although the code you are modifying is from before we adopted this
convention.
{{{
self._chan_label.props.xalign = 0.0
}}}
I know you are following the local convention in that code, but I really
dislike using abbreviations in identifiers.
{{{
ip_address_text = "%s: %s" % (_("IP address"), ip_address)
}}}
The same string appears two times and thus will be offered for translation
two times. Perhaps we can add a constant to
view/devices/network/__init__.py?
0003--2866-wireless-mesh-frame-icons-pulse-while-connecti.patch
{{{
self._icon.props.base_color = pulse_color # only temporarily
}}}
What this comment mean?
--
Ticket URL: <http://dev.laptop.org/ticket/2866#comment:24>
One Laptop Per Child <http://laptop.org/>
OLPC bug tracking system
More information about the Bugs
mailing list